Slow message sending and media sending failures

Incident Report for Blip

Resolved

This incident has been resolved.
Posted Jun 23, 2026 - 21:40 GMT-03:00

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 23, 2026 - 20:25 GMT-03:00

Investigating

We have identified slow message sending and media upload failures.
As a result, customers have experienced/are experiencing/may experience media upload failures, with the error "Media upload error: Downloading media from weblink failed with http code 500, status message Timed out waiting for session" occurring.
Posted Jun 23, 2026 - 20:09 GMT-03:00
This incident affected: Channels (WhatsApp).