Blip Desk Instability
Incident Report for Take Blip
Resolved
Customer Impact:

Slow access to the Desk.

Details of the scenario identified by the platform team:

We found that an internal programming language tool used in the construction of the Desk application was consuming a lot of machine processing and taking too long to release the application to continue its execution. This impacts the application because the application is “suspended” for a very high time interval, which generates a delay in the processing of requests that is noticeable by the user.

What is causing the identified failure:

Slow to load information from the desk, conversation history, pull tag.

Temporary solution applied: It was solved with intervention in the Desk. Since Tuesday the platform team in the investigation

Definitive solution in progress:

A configuration was implemented in an internal tool of the programming language used in the construction of the application so that it can adapt to the load that is arriving at the Desk (Number of tickets, and messages trafficked), this load has increased in the last months in the Take cluster, justifying why the failure occurred only in this cluster.

On February 11, 2021, the configuration was increased in three of the 06 servers in our structure.
We are evaluating the risk of increasing the configuration change to the other servers this Friday (02/12/2021)

As long as the actions are not 100% implemented, the Technical Support team is performing an intervention in the Desk service with the objective of resolving it in a palliative way.

The intervention resolves why the service restart does the cleaning, which should be done in an automated way by the tool of the programming language used in the construction of the application.

Start date / time: 11:30
End date / time: 12:20
Posted Feb 12, 2021 - 12:20 GMT-03:00
Update
We are continuing to investigate this issue.
Posted Feb 12, 2021 - 11:53 GMT-03:00
Investigating
In monitoring, we identified an instability in the BLIP DESK service tool.
Please wait for new information
Posted Feb 12, 2021 - 11:35 GMT-03:00
This incident affected: Desk.