[Blip Desk and Portal] - Degradation

Incident Report for Blip

Postmortem

Start Time: 24/08/2024 ~21:00 (GMT-3)
End Time: 24/08/2024 ~22:07 (GMT-3)

Incident Summary:
The Desk and the Portal (in the sections that communicate with information from the Desk, such as the Service tab) were slow to display data.

Impact Analysis:
This incident resulted in slowness on the Desk screen (attendant's view), slowness in searching for attendants, delay in loading Portal pages related to the Desk (service menu), such as monitoring and service reports.

Mitigation Measures:
The environment was restored without technical interventions on our part, while we investigated the scenario.

Root Cause Analysis
The technical team analyzed what happened and concluded that there was an overload in our database. This overload made requests to the bank unfeasible, causing the perceived slowness in the use of services.

To ensure that the episode does not repeat itself, we balanced the queries in the database, so that no further overload occurs.

Posted Sep 17, 2024 - 14:36 GMT-03:00

Resolved

This incident has been resolved.
Posted Aug 24, 2024 - 23:30 GMT-03:00

Monitoring

A fix has been implemented and we are monitoring the results.
At the moment, we are monitoring the entire environment.
Posted Aug 24, 2024 - 22:05 GMT-03:00

Investigating

We are experiencing unexpected behavior on Blip Desk and Portal application.

Impact:

Possible symptoms noticed: slowness on the Desk screen (attendant's view), slowness in searching for attendants, delay in loading the Portal pages related to the Desk (service menu), such as monitoring and service reports.
Posted Aug 24, 2024 - 21:10 GMT-03:00
This incident affected: Desk and Blip Platform (Portal).